Crowdstrike Windows Event Logs, The Hello folks, I'm still trying to figure out how to analyze detections from Crowdstrike. CSWinDiag gathers information about the state of the Windows host as well as log files and packages them up into an archive file which you can send to CS Support, in either an open case Use a log collector to take WEL/AD event logs and put them in a SIEM. This activity should only occur during planned events and any instances We have dozens of windows 11 pro workstations where the security event log records thousands of entries per day with event id 5038. Crowd Inspect Host-Based Process Inspection How To Read Details of usage and reported results can be found in the About CrowdInspect section of the tool once launched. Sometimes, newer versions of operating systems can have compatibility issues with existing software, including security tools like Interestingly I do see services like Veeam and Windows internal services start and stop when I run a query against the host I want to watch. Each source is paired with a matching hec sink What OS are we talking about? In windows at least, it generates logs in the event viewer under the Application section whenever it changes to a another version, so you can figure out the change How to identify hosts possibly impacted by Windows crashes Published Date: July 19, 2024 Objective » Identify Microsoft Windows hosts potentially impacted by crashes » Scope impact For those new to CrowdStrike, end user notifications on Windows 7 & 8 utilize balloon notifications, while Windows 10 and macOS uses toast-style messages. We have dozens of windows 11 pro workstations where the security event log records thousands of entries per day with event id 5038. Detects delete events on the CrowdStrike registry keys. Event Hubs are data/event ingesters which can be integrated with functions and services (Azure internal and external). That’s according to an update made last night to CrowdStrike’s statement on yesterday’s global outage, After the Crowdstrike BSOD’s on 19/07/2024 – we have seen a significant uptick on clients not refreshing group policy. However, the particular service that I want to track doesn't Topline Scores of Microsoft Windows users are facing outages due to a problem with CrowdStrike’s cybersecurity software, shuttering companies When the CrowdStrike outage occurred, numerous Windows 11 desktops were left unable to function. It allows the user to filter out any results (false positives) without editing the SPL. Some key things to look for include: Event ID 14 from the Microsoft-Windows Crowdstrike Falcon is a cloud-based platform that provides endpoint protection across your organization. This method is supported for Crowdstrike. The local Cribl Edge deployment will collect the event data from the monitored file and push it to the Cribl Cloud Proficiency with query languages such as Splunk SPL or KQL for log analysis Solid grasp of endpoint OS internals (Windows event logs, process trees, registry, macOS/Linux equivalents) Fixing CrowdStrike Issue on Windows Author (s): Louis Ouellet Recently, there was a significant issue involving CrowdStrike and Microsoft CD C:\Windows\System32\drivers\CrowdStrike Note In this example, C is your system drive. A defective CrowdStrike update sent computers around the globe into a reboot death spiral, taking down air travel, hospitals, banks, and more with it. The guide covers the Safe Mode workaround and the recovery steps to get I tried running the Windows Recovery Tool from Microsoft (both Windows PE and Safe mode) (KB5042429: New recovery tool to help with CrowdStrike issue impacting Windows devices - I tried running the Windows Recovery Tool from Microsoft (both Windows PE and Safe mode) (KB5042429: New recovery tool to help with CrowdStrike issue impacting Windows devices - I'm attempting to look for the reason for a device containment, where can I view these audit logs for analyst comments when containing a device? It doesn't appear in host management and obviously Consolidate all your log data onto one powerful platform and unify log collection with the lightweight CrowdStrike Falcon® sensor. The CrowdStrikeDetections table contains logs from the CrowdStrike Detections API that have been ingested into Microsoft Sentinel. Falcon Next-Gen SIEM’s index-free Learn from the Microsoft-CrowdStrike incident with 12 key lessons and QA tips to enhance your software development and release processes. By routing Software Operating Systems Windows How to fix CrowdStrike BSODs in three minutes — fix requires manual changes, but they are simple How-To By We would like to show you a description here but the site won’t allow us. The thought is I want a place where I can do a search like: show me all registry key changes with the following string: Welcome to our seventh installment of Cool Query Friday. As Event Hubs are often used as Chronology of the CrowdStrike update bug that caused BSOD in Windows, impact and measures taken to mitigate the consequences. Although this was not a Microsoft incident, given it • CrowdStrike Token Refresh Check: Monitors the CrowdStrike Event Streams log file to detect if an input has stopped running and attempts to disable and re-enable it*. Look for System and Application Viewing Event Logs in Real-time Response is made difficult for two reasons: There's a lot of content in event log data. Security, application, system, and DNS events are some examples of Windows Event logs, and they Welcome to the Falcon Query Assets GitHub page. Threat Detection: Identifying Suspicious PowerShell Activities Using CrowdStrike Logs PowerShell is a handy built-in tool on Windows that makes life Can someone please advise for creating task via BigFix console to uninstall CrowdStrike windows sensor ? We have dozens of windows 11 pro workstations where the security event log records thousands of entries per day with event id 5038. We have Crowdstrike Falcon sensors on all of our The base query we’ll use to see all Windows logon events is as follows: index=main sourcetype=UserLogon* event_simpleName=UserLogon event_platform=win | search Yes, it’s very beneficial. And there are What might be considered the largest IT outage in history was triggered by a botched software update from security vendor CrowdStrike, affecting millions of Windows systems around the Is there a better way than the collector agent to ingest windows logs? If not, how can I do some preprocessing of the log event messages before it gets to the rawstring? Investigate Microsoft PowerShell and how it opens up capabilities for attackers & more cybersecurity tips & information on the CrowdStrike blog! There is an ongoing issue where a bad CrowdStrike update has caused systems worldwide to fail to boot Windows and blue screen to WinRE after the failed boot attempts For Learn more about the technical details around the Falcon update for Windows hosts. We have Crowdstrike Falcon sensors on all of our You can use Real-Time Response (RTR) to access the AD server and export or query the Windows Event Logs, but that is where the event you’re looking for will be. User productivity tracking is a different space altogether. Las guías paso a paso están disponibles para Windows, Mac y Linux. I am trying to figure out if Falcon collects all Windows Security event logs from endpoints. The machines in question can be identified via: The last update file date What is CrowdStrike, and what happened? The cybersecurity giant CrowdStrike brought down thousands of systems after pushing a faulty update to 👉 https://amzn. 1 Fixed GB to Kb on log size WSplunkLCS: The Falcon Log Collector integrates natively with CrowdStrike Falcon Next-Gen SIEM, targeting its ingest API to deliver actionable insights. You can turn on more verbose logging from prevention policies, device control and when you take network containment actions. TryHackMe Windows Event Logs Write-Up After learning about the tool suite, Sysinternals, we are now going to be learning about logs, specifically Windows Event Logs. Summary As a follow-up to the CrowdStrike Falcon agent issue impacting Windows clients and servers, we have released an updated recovery tool with two repair In response, Microsoft on Saturday released a recovery tool to help repair Windows machines affected by the bug, a day after CrowdStrike provided We would like to show you a description here but the site won’t allow us. CSWinDiag gathers information about the state of the Windows host as well as log files and packages them up into an archive file which you can send to CS Support, in either an open case (view CASES from the menu in the Support Portal), or by opening a new case. Pull logs from the CrowdStrike Event Streams API. This will change to the CrowdStrike directory. So I headed to Event Search to try and find this information. How to Perform a Simple Machine Search with the CrowdStrike Falcon® Investigate App CrowdStrike Falcon® streams endpoint activity data to the cloud in real time. 4 Simple query for checking ingest volume on specific logs (sharing) Next Gen SIEM (self. When entire sectors are shitfting, it’s usually quite hard to follow the tides, but this blog post is trying to make easier to at least mount a little wave, by We have dozens of windows 11 pro workstations where the security event log records thousands of entries per day with event id 5038. Learn how the Microsoft Recovery Tool With Tamper Protection enabled, the CrowdStrike Falcon Sensor for Windows cannot be uninstalled or manually updated without providing a computer-specific We would like to show you a description here but the site won’t allow us. All activities resulting in a notification, Learn how to collect CrowdStrike Falcon Sensor logs for troubleshooting. These keys are removed as part of the agent uninstallation process. I’m This document is designed for customers that want to use Cribl as the central ingestion and distribution platform for CrowdStrike Event Stream API data. This incident led The CrowdStrikeVulnerabilities table contains logs from the CrowdStrike Vulnerabilities API that have been ingested into Microsoft Sentinel. We have Crowdstrike Falcon sensors on all of our CrowdStrike is a global cybersecurity leader with an advanced cloud-native platform for protecting endpoints, cloud workloads, identities and data. CrowdStrike has a new status dashboard for IT workers affected by Windows BSODs. Many industries are affected by computers receiving the Windows blue screen of death, and the IT community has already stepped up to try to help fix the problems. We would like to show you a description here but the site won’t allow us. Each source is paired with a matching hec sink Collect Crowdstrike Diagnostic Logs - Free download as PDF File (. Step-by-step guides are available for Windows, Mac, and Linux. Contribute to nkoziel/Crowdstrike development by creating an account on GitHub. We are working with This guide covers the deployment, configuration and usage of the CrowdStrike Falcon® Event Streams Technical Add-on (TA) for Splunk v3 and above. CrowdStrike Falcon offers cloud-delivered solutions across endpoints, cloud workloads, identity and data; providing responders remote visibility across the enterprise and enabling instant access to the This search is designed to identify file downloads of the defective CrowdStrike content update on Windows systems by querying CrowdStrike sensor logs. crowdstrike) submitted 23 hours ago by cobaltpsyche Sometimes when trying to keep ingest under the limit, we The CrowdStrike Outage Timeline As we are all very aware, being a technical person or layman, the recent CrowdStrike outage caused disruptions on a myriad of systems worldwide, Since the majority of Microsoft’s infrastructure for the Azure cloud, Office 365, and even their Xbox gaming services is built on the Windows OS, the Overview This document outlines the deployment and configuration of the technology add-on for CrowdStrike Falcon Event Streams. The format will be: (1) description of what we're doing (2) walk though of each step (3) application in the wild. For the CrowdStrike issue, one can use both monitored Windows System logs and the Dynatrace entity model to find out what servers are This document provides instructions for collecting diagnostic logs from CrowdStrike on macOS and Windows endpoints. Inside the 78 minutes that took down millions of Windows machines CrowdStrike’s faulty update has kicked off questions about how to avoid a similar Event ID 4624 is a security event that gets generated in the Microsoft Windows event log every time a user successfully logs on to a computer or CrowdStrike LogScale ingester for Azure AD logs This repository contains a collection of Azure Functions to process events in Event Hub and ingest the Obtenga información sobre cómo recopilar los registros de CrowdStrike Falcon Sensor para la solución de problemas. So I receveid this detection: IOA NAME: CommandLineKnownMalware IOA Welcome to the CrowdStrike Tech Hub, where you can find all resources related to the CrowdStrike Falcon® Platform to quickly solve issues. This can also be used It uses the wineventlog source to monitor critical Windows event channels and a syslog UDP listener to receive logs from external devices. I don't want to switch to using CS Firewall for managing Windows Firewall - but it A faulty update from antivirus provider CrowdStrike triggers the Blue Screen of Death on numerous Windows PCs. We are working with On Windows systems, Channel Files reside in the following directory: "C:\Windows\System32\drivers\CrowdStrike" and have a file name that starts with Here, we are obtaining all event logs locally, and the list starts with classic logs first, followed by new Windows Event logs. windows_get_variable_exe_execution_from_windowsapps_folder_filter is an empty macro by default. Dear customers, We are aware that many of you are encountering issues with your Windows systems due to a problem with CrowdStrike’s Falcon Sensor. . When CrowdStrike pushed an update to the Falcon software, which interacts with other parts of computer systems and software like Microsoft’s Windows products, it caused a malfunction The CrowdStrikeHosts table contains logs from the CrowdStrike Hosts API that have been ingested into Microsoft Sentinel. Summary As a follow-up to the CrowdStrike Falcon agent issue impacting Windows clients and servers, we have released an updated recovery tool with two repair Windows Event logs contain data relating to events that occur on the Windows operating system. The update, intended to Learn how to fix the CrowdStrike bug on Windows that's causing BSODs and rendering millions of computers inoperable. It is possible to have a log’s RecordCount be zero or null. Here, we’ll provide you Introduction This document will show you how to repair a broken sensor if you either deleted or modified the folder C:\Windows\System32\drivers\CrowdStrike or its content as a response to the Falcon Agent-less log collection mode The NXLog Enterprise Edition can be configured to collect event log data remotely in an agent-less mode without directly installing it on the endpoints and On a Windows 7 system and above, this file is located here: C:\Windows\System32\winevt\Logs\Microsoft-Windows-Sysmon%4Operational. Whether On July 18, 2024, CrowdStrike released an update to its Falcon platform that inadvertently caused Windows systems to crash. - Correlate the alert with Use a log collector to take WEL/AD event logs and put them in a SIEM. It uses the wineventlog source to monitor critical Windows event channels and a syslog UDP listener to receive logs from external devices. Read more about the new recovery tool and usage instructions at New Recovery Tool to help with CrowdStrike issue impacting Windows endpoints. This guide demonstrates how to combine the Microsoft has released an official fixing tool to automatically repair broken Windows PCs and laptops impacted by CrowdStrike faulty update. CrowdStrike Query Example # Get all events from UserLogonFailed2 event_platform=win event_simpleName=UserLogonFailed2 # Convert Learn how to collect CrowdStrike Falcon Sensor logs for troubleshooting. How to Confirm that your CrowdStrike installation was successful Since the CrowdStrike agent is intended to be unobtrusive to the user, knowing if it's been installed may not be obvious. You may like Save yourself from a bad Windows 11 update with these recovery tips In this how-to guide, I will explain how to quickly fix the CrowdStrike Here are some examples of how you can use CrowdStrike EDR logs in Microsoft Sentinel: Create detections: You can use CrowdStrike EDR logs to If the CrowdStrike outage has left Windows machines stuck on a blue screen, this is the fast path back in. It looks for events where the This document outlines the deployment and configuration of the technology add-on for CrowdStrike Falcon Event Streams. I was able to find Event ID 6 from FilterManager and Event ID 7045 from Service Control Manager in the System Windows Event Log which indicates when the CSAgent filter and CrowdStrike-related An event is any significant action or occurrence that's recognized by a software system and is then recorded in a special file called the event log. 10] We have received reports of successful recovery from some customers attempting multiple restart operations on affected Windows servers. These endpoints might encounter error We would like to show you a description here but the site won’t allow us. Facing a BSOD crisis after the CrowdStrike update? Here’s how to recover your Windows system and avoid future disruptions from security updates. evtx This log file is in Hi I am trying to create a PS script so I can view the "Windows Defender" event logs on a remote computer via PSFalcon however I can't seem to get the output readable as I would when I run the We have received reports of successful recovery from some customers attempting multiple restart operations on affected Windows servers. CrowdStrike fault update to its Falcon Sensor driver to blame for the Blue Screen of Death on Windows systems. Even still, the sensor doesn't generate a specific event when a user locks, but does not logout from, a Windows system so there isn't a Review Event Viewer: If you’re comfortable navigating through the Windows Event Viewer, you can check for logs related to the BSOD occurrences. If so, can you deploy CS Firewall in "audit" mode, without it taking over and registering in Windows Security Center. Issue How do I collect diagnostic logs for my Mac or Windows Endpoints? Environment CrowdStrike Resolution Collecting Diagnostic logs from your Mac Endpoint: The Falcon Sensor for Check the current Azure health status and view past incidents. Effective log management is an important part of system administration, security, and application development. We have Crowdstrike Falcon sensors on all of our The CrowdStrike Falcon sensor does not have a standard application log file within the home directory of the sensor. Here's what happened and what to do to fix the issue. Currently we are running 95% on our Splunk license and have been asked to do a full analysis of the benefits ingesting Crowdstrike fdr logs in to the Splunk vs ingesting the logs via Splunk uf. This hides the true intent of the We would like to show you a description here but the site won’t allow us. It collects its version of events it thinks are potentially relevant from a security standpoint. This technical add-on (TA) facilitates establishing a connecting Gain unified visibility and secure your environment by easily ingesting generic security logs and events from Microsoft Azure Event Hubs into the CrowdStrike Remember my email Continue CrowdStrike Falcon sensor updates has widespread Blue Screen of Death errors on Windows systems globally. Here's how to fix this. to/4aLHbLD 👈 You’re literally one click away from a better setup — grab it now! 🚀👑As an Amazon Associate I earn from qualifying purchases. on Thursday, July 18, a faulty update from CrowdStrike (software installed on Windows computers that provides protection against threats, If the attack was against a small set of hosts you could also check a few of the suspected destinations' Security Windows Event Logs to see failed auth attempts. pdf), Text File (. Once in the CrowdStrike directory, locate the file matching “C CrowdStrike Resources On July 19, 2024, a faulty update to CrowdStrike's security software caused widespread crashes of computers and virtual machines running Microsoft Windows. This document provides instructions for collecting diagnostic logs from CrowdStrike on macOS In this article, we’ll look at how to catch malicious PowerShell behaviour using CrowdStrike Falcon logs, with practical queries SOC analysts In part 4 of the Windows logging guide we’ll complement those concepts by diving into centralizing Windows logs. EventStreams logs. Includes GUI and silent installation methods, verification steps, Logging The CrowdStrike Falcon sensor does not have a standard application log file within the home directory of the sensor. Here, we will publish useful queries, transforms, and tips that help CrowdStrike customers write custom hunting syntax and better leverage the Falcon Explore CrowdStrike NG-SIEM Log Ingestion supported sources and best practices to optimise visibility, reduce noise, and strengthen enterprise threat detection. CQL Hub - CrowdStrike Query Library Open library of detection & hunting queries for Falcon NextGen SIEM and LogScale. How To Install There is no We would like to show you a description here but the site won’t allow us. Date: 2025-01-23 ID: cbb06880-9dd9-4542-ac60-bd6e5d3c3e4e Author: Patrick Bareiss, Splunk Description Logs process-related activities captured by CrowdStrike, including process creation, DEFINITIONS:: WINDOWS LOGGING CONFIGURATION: Before you can gather anything meaningful with Logscale, or any other log management solution, the Windows logging and auditing must be Facing a blue screen on Microsoft Windows? Learn about the CrowdStrike update causing the BSOD and find a temporary solution to resolve it. Real-time Response has a maximum amount of characters it can return in a single Do you use CrowdStrike Event search heavily? Do you come up against the 7-day data retention limit? Do you want to keep some data longer and still search it? This article explains how to The CrowdStrikeAlerts table contains logs from the CrowdStrike Alerts API that have been ingested into Microsoft Sentinel. The installer log may have been overwritten by now but you can bet CrowdStrike Falcon offers cloud-delivered solutions across endpoints, cloud workloads, identity and data; providing responders remote visibility across the enterprise and enabling instant access to the Update Log: Crowdstrike Logscale Windows Logging Cheat Sheet Released Feb 2024 Humio Cheat Sheet Retired Feb 2024 SysmonLCS: Jan 2020 ver 1. The CrowdStrike Falcon® Event Streams Technical Welcome to our twenty-seventh installment of Cool Query Friday. The company has already fixed the problem and is working with customers to There is a known workaround for the blue screen CrowdStrike error that many Windows computers are currently experiencing. txt) or read online for free. This technical add-on (TA) facilitates establishing a connecting to the Were any system event logs cleared? UUID: b85d4036-8c25-49c1-ab1a-04a45c57bf5a ID: Q1074 Approaches to Answer Search CrowdStrike logs for indicator removal on host [Q1074. Fortunately, there's a (slightly Harun Ozalp/Anadolu via Getty Images [Updated 24-July with details from CrowdStrike's preliminary post-incident review] Microsoft Windows powers A CrowdStrike update is breaking computers running Windows. This can also be used on Crowdstrike RTR to At a high level, CrowdStrike recommends organizations collect remote access logs, Windows Event Logs, network infrastructure device logs, Unix system logs, Learn how to collect CrowdStrike Falcon Sensor logs for troubleshooting. We are working with CrowdStrike has launched a dashboard within the Falcon portal interface that will identify impacted Windows systems within your environment. What is best practice for collecting and forwarding data from 1000s of Windows endpoints (both workstations and servers) to Logscale? Other SIEMs I have used manage this for you and tell you What is best practice for collecting and forwarding data from 1000s of Windows endpoints (both workstations and servers) to Logscale? Other SIEMs I have used manage this for you and tell you Does Crowdstrike only keep Windows Event Log data for a set period regardless of settings or timeframes applied in queries? I have a query that I run to pull RDP activity based on Windows Event windows_onedrive_share_mounted_via_net_filter is an empty macro by default. In this first post of our Windows Logging Guide series, - Check for any recent changes or additions to the WMI repository, including new namespaces or classes, which could indicate malicious activity or persistence mechanisms. We have received reports of successful recovery from some customers attempting multiple restart operations on affected Windows endpoints. This article covers a guide on how to troubleshoot ingestion issue after Windows blue screening issue due to faulty CrowdStrike update event. Learn how to collect CrowdStrike Falcon Sensor logs for troubleshooting. Does CrowdStrike perform endpoint logging as a service? For security purposes, I need a solution that captures standard event logs on employee laptops, but I'm new to CrowdStrike and couldn't figure Updated Date: 2026-04-13 ID: 2ba4b456-76e2-439d-bca6-fd5ef24cc53b Author: Raven Tait, Splunk Type: TTP Product: Splunk Enterprise Security Description Detects the IOBit Unlocker Extension How to Install the CrowdStrike Falcon Sensor on Windows Install CrowdStrike Falcon sensor on Windows with our complete guide. Here’s how to do it. For macOS, users can utilize the built-in diagnostic tool via terminal commands, Updated Date: 2026-04-13 ID: 4f8cd681-7583-47a0-9f38-6337b7adf48a Author: Raven Tait, Splunk Type: Anomaly Product: Splunk Enterprise Security Description By default, the Windows guest Description Detects command obfuscation by using a technique to build a target command using character indexes from environment variables. You can now recover a PC affected by the CrowdStrike outage without BitLocker recovery keys, at least in certain situations. Summary Microsoft has identified an issue impacting Windows endpoints that are running the CrowdStrike Falcon agent. m. This is causing unexpected system behaviour, Learn how to integrate CrowdStrike Falcon logs with Splunk using a step-by-step approach. About Best Practices, queries, and packages for CQL the language of CrowdStrike's LogScale (Humio) log manager. Learn how you can integrate the SQL Server error logs into Crowdstrike for better analysis. windows_set_custom_dns_serverlevelplugin_via_dnscmd_filter is an empty macro by default. Improve your security monitoring, incident response, and analytics by CrowdStrike is an AntiVirus product typically used in corporate/enterprise environment. Instead, the application sends sensor logging messages into windows_appcertdll_modification_via_command_line_filter is an empty macro by default. The format will be: (1) description of what we're doing (2) walk though of each step (3) application in the We would like to show you a description here but the site won’t allow us. Hey Guys, I am looking to find something in PowerShell that would help us in getting and downloading the Application, System and Security Logs On July 18, CrowdStrike, an independent cybersecurity company, released a software update that began impacting IT systems globally. Remember that crowdstrike isn’t capturing every windows event log. 2021-03-12 - Cool Query Friday - Parsing and Hunting Failed User Logons in Windows : r/crowdstrike r/crowdstrike Current search is within r/crowdstrike Remove r/crowdstrike filter and expand search to Hi there. If you currently use Crowdstrike Falcon, you can configure the Falcon SIEM Connector to send Find the updated dashboard at: Next-Gen SIEM > Log management > Hosts possibly impacted by windows crashes granular status Note: The Dashboard cannot be used with the "Live" The SIEM Connector will process the CrowdStrike events and output them to a log file. How to fix CrowdStrike's blue screen of death on your PC First, CrowdStrike itself has already rolled back the update, but many machines are CrowdStrike provides guidance on running an advanced Windows event log search to flag these systems. IN addition to creating custom view and using PowerShell to filter Windows event logs, this guide will look at important Windows security events, how to use Task Scheduler to trigger automation with IN addition to creating custom view and using PowerShell to filter Windows event logs, this guide will look at important Windows security events, how to use Task Scheduler to trigger automation with This Powershell can be used on a windows machine to collect logs for traiging/investigating an event. Instead, the application sends sensor logging messages into the Purpose of this Powershell Script This Powershell can be used on a windows machine to collect logs for traiging/investigating an event. I am seeing logs related to logins but not sure if that is coming from local endpoint or via identity. Updated on July 19, 2024: A new Registry Please enable Javascript to use this application Check CrowdStrike Falcon Sensor Status: Verify Sensor Running (Windows/Mac/Linux) Verify CrowdStrike Falcon sensor is running with step-by-step commands for Windows (sc query csagent), Worldwide outage Starting at 9:30 p. Let's go! CommandHistory Learn how to open and navigate Windows Event Viewer and understand the 5 log categories so you can identify and analyze critical problems. tv nb e5 lvf1 lme 0eq 59 6yihutw clq uu